Friday, April 25, 2014

Install pysaml2 with pip

You need these packages to be able to install pysaml2 successfully with pip:

trinh@trinh-pc:~$ sudo apt-get install libxml2-dev libxmlsec1-dev libffi-dev xmlsec1

trinh@trinh-pc:~$ source /myvenv/bin/activate

(myvenv)trinh@trinh-pc:~$ pip install repoze.who xmlsec mako python-memcache

(myvenv)trinh@trinh-pc:~$ pip install pysaml2