Tuesday, March 4, 2014

DBeaver 2.3.6 and 2.3.7 : no more wizard for new connection

If you are using DBeaver version 2.3.6 or 2.3.7, you will encounter this error when you create a new connection:

problem Occured, Problem Openning Wizard, The Selected wizard could not be started. in details :
The selected wizard could not be started. 
Plug-in "org.jkiss.dbeaver.core" was unable to instantiate class "org.jkiss.dbeaver.ui.dialogs.connection.NewConnectionWizard".

It is a bug. So, just update DBeaver to 2.3.8 or higher, this issue will be fixed.

Reference: http://dbeaver.jkiss.org/forum/viewtopic.php?f=2&t=1160