Posts

Showing posts with the label forwarding graph

Error when creating Forwarding Graph in OpenStack Tacker

The problem when you learn something by reading old blog posts is that the technology may have already been changed since the date of the post so you're most likely to get into trouble just like me. I followed some tutorial online about creating a VNF forwarding graph or a service function chain in OpenStack tacker and got this error: $ tacker vnffg-create --vnffgd-name VNFFG-TEMPLATE MY-VNFFG BadRequest: Flow Classifier conflicts with another Flow Classifier 564c5506-8fe7-4b1d-b76d-8eb1768463aa According to the error above, I tried to delete the flow classifier: $ neutron flow-classifier-list $ neutron flow-classifier-delete <the classifier ID> and I got a new error... what? BadRequest: FlowClassifier a5b3185a-4d2b-41a0-a54d-5cdea5ae2bed does not set logical source port in ovs driver I'd looked everywhere for clues but jeez... helpless!!! It turned out that the vnffgd TOSCA syntax has been changed to address the multiple flow classifiers (I'm running...

"ip_proto" parameter in Tacker VNF Forwarding Graph TOSCA template

Here are the list of the available values of the "ip_proto"  (IP Protocol number) in the TOSCA template for the Tacker VNF Forwarding Graph: Decimal Keyword Protocol IPv6 Extension Header Reference 0 HOPOPT IPv6 Hop-by-Hop Option Y [ RFC8200 ] 1 ICMP Internet Control Message [ RFC792 ] 2 IGMP Internet Group Management [ RFC1112 ] 3 GGP Gateway-to-Gateway [ RFC823 ] 4 IPv4 IPv4 encapsulation [ RFC2003 ] 5 ST Stream [ R...